A Process for Creating Line Drawings of Sign Language from Digital Color Photographs

A “Subtractive” Technique Utilizing Photoshop

May 2, 2006

PEN-International
National Technical Institute for the Deaf
Rochester Institute of Technology
U.S.A.
A Process for Creating
Line Drawings of Sign Language
from Digital Color Photographs

A “Subtractive” Technique
Utilizing Photoshop

May 5, 2006

PEN-International
National Technical Institute for the Deaf
Rochester Institute of Technology
52 Lomb Memorial Drive
Rochester, NY 14623
USA

www.pen.ntid.rit.edu

By

Yoko T. Supernavage, Consultant, PEN-International
E. William Clymer, Coordinator, PEN-International

With Support from

RIT
Educational Technology Center

Based on Work of Students from
Dong Nai Provincial Teacher’s College
Vietnam

PEN-International is funded by a grant from
The Nippon Foundation of Japan to NTID

L:\Current Projects\Sign_Lang_HK_Vietnam 05-06\Final Training Book\PDF_Files\ALL_Sign_Final.pdf
Table of Contents

Project Overview .............................................................................................................. 4

How to Use These Materials .......................................................................................... 6

How to Take a “Sign” Picture .......................................................................................... 7

How to Create a “Sign” Line Drawing in Photoshop ......................................................... 9

How to Insert Sign Drawings into Word .......................................................................... 16

How to Add Arrows and Notations to Drawings in Word ................................................. 18

How to Use the Custom Shapes Tool to Add Standardized Notation to Sign Drawings .......................................................................................................................... 19

How to Create an Arrow in Illustrator and Insert it into Word ...................................... 26
Project Overview

PEN-International, an international project, funded by the Nippon Foundation, and housed at the National Technical Institute for the Deaf, Rochester Institute of Technology, is working with an international team of linguistic experts who are documenting and disseminating indigenous sign languages in Asia.

Background

Deaf communities, as well as schools and universities, have a natural and strong desire to document, analyze, document and disseminate sign language dictionaries, usage guides and curriculum in order to preserve their natural language and to ensure those learning the language are provided with the most accurate vocabulary and grammar available. This is particularly true in Vietnam, Hong Kong, Cambodia, Thailand, and the Philippines, where PEN-International and the Nippon Foundation are working to support such endeavors.

Problem Obtaining Accurate Sign Drawings and Photos

It is difficult to capture accurate sign language images in a form that can clearly notated and reproduced for analysis and reproduction. Most successful sign language books and materials depend on clear, information laden line drawings or photographs, that show signs (frequently in compound views showing initial and terminal position) along with a notation system indicating motion and other key elements of the sign production. The problem is that the creation of sign language drawings has in the past required artistic drawing and rendering skills. Most of the individuals involved in the collection of sign language resources are not artists and must employ artists to create necessary visuals. This is costly, time consuming and introduces frequent errors.

A Solution

PEN-International, working with deaf specialists and linguists in Vietnam, Hong Kong and the Philippines has made some significant strides in using Adobe imagining products to convert digital photographs of signs to accurate line drawings, by persons who are not professional artists. (See below)
The NTID process relies on converting a digital image to line drawings using various image manipulation techniques within Photoshop and then erasing segments of the image that are not necessary. This subtractive process does not require any artistic ability, yet the final images are extremely accurate and contain the facial expression and other subtle body language signals so important in sign language.

The techniques that produced the above images were reviewed by local experts in Vietnam, Hong Kong and the Philippines in March 2006. There was universal agreement that it is a vast improvement in the rudimentary techniques used in the past. However, issues related to compound images, “skin on skin” contrast and continuous tone image reproduction remain to be solved.

Future Work

NTID is committed to refining the process of generating sign language drawings and photographs and producing training resources that can be used by Asia teams creating local sign language materials. This work will be shared with at the 9th Asia-Pacific Congress on Deafness in Japan in October 2006.

With sufficient additional support, PEN-International seeks to establish a sophisticated digital image graphic production capability for each of the five PEN partner sites, including online distribution centers for each country. Essentially each partner country will produce sign language resources and curriculum, using Adobe Photoshop, Illustrator and InDesign. Final publication will occur through Adobe Acrobat for “on demand” downloading from the web or through such on-demand printing services such as lulu.com in the USA.

Upon the successful implementation of the print components of the project, PEN-International would like to expand the creation and distribution of the sign language materials to include brief video segments of each sign in the print dictionaries produced by each partner country. The current plan is to use Adobe Premiere to compile instructive video segments and then include them in the Adobe Acrobat publications so users of DVD versions of the documents will be able to view actual footage of the signs on personal computers.
How to Use These Materials

These materials are in the formative development stage of publication, which means they are constantly evolving and being revised and expanded.

They are written concisely so that individuals familiar with both the documentation of sign language images, and a moderate understanding of Adobe Illustrator and Microsoft Word, can use them as reference during production phases. They are not intended to provide background and perquisite training, only specific instructions on the use of specific software packages so the reader can replicate the processes described.

The processes described in these documents utilize Adobe PhotoShop CS (Mac or Windows) and Microsoft Word 2003 (Mac or PC). Some additional processes are described that utilizes Adobe Illustrator, but these processes are not generally used by most developers.

Copies of the most recent version of this document, along with the sample files mentioned can be obtained from the authors.
You need:
- Digital Camera
- Tripod
- Large Bright Green Background
- Black T-shirt

Sample digital camera:
*Canon Powershot SD550 (7-megapixel)*

** A sign model *should not* wear jewelry (necklace, rings) or eye glasses.
TOP VIEW

Wall

Model

Camera

(1.5M ~ )

(1.5M ~ )

Camera:
- Shoot vertical, on a tripod
- Highest resolution possible
- Use “auto flash”

Original image

Cropping of final image
How to Create a “Sign” Line Drawing in Photoshop

For PC User

(1) Open the image in Photoshop CS or higher
File > Open

This instruction is based on the photo that is taken by 7-megapixel digital camera.

Save as Photoshop

(2) Crop the image if necessary --- click Crop Tool

(Example)
(1) With : 5 cm
(2) Height : 5 cm
(3) Resolution : 300

Changing Units
(inch ↔ cm)
Edit>Preference>
Unit &Rulers...

Zoom Tool
+ Alt =

For Mac User

Save as
Photoshop

Open the image in Photoshop CS or higher
File > Open

Changing Units
(inch ↔ cm)
Edit>Preference>
Unit &Rulers...

Zoom Tool
+ Alt =

Save as
Photoshop

Open the image in Photoshop CS or higher
File > Open

Changing Units
(inch ↔ cm)
Edit>Preference>
Unit &Rulers...

Zoom Tool
+ Alt =
(3) **Image > Adjustments > Replace Color**

- **Adjust fuzziness:** 100

- Pick **Eyedropper** and click somewhere on the **green** background

- Pick **Add to Sample Eyedropper** and click a few times on the hues of green to select all the green area
- Put lightness: +100%

Click **OK**

The image should look like this:
(4) **Image > Adjustments > Levels**

*** Adjust (a) (b) (c) to get a high contrast image

*(Example)*
(a) Input Black Point : 50  
(b) Gamma (midpoint): 1.5  
(c) Input White Point : 225  

*(input may differ depending on the image)*

Click **OK**

(5) **Reset Swatches**

- Foreground Color : **Black**  
- Background Color : **White**

Click here to make foreground **black** and background **white**
(6) **Filter > Sketch > Photocopy**

***Adjust **Detail** & **Darkness** until you get nice, sharp outlines***

*(Example)*

- Detail: 2
- Darkness: 25

*(Input may differ depending on the image)*

**Zoom Command** to zoom in or out an image

Click **OK**
(7) Pick **Erase Tool**

Click this arrow to adjust diameter depending on the image

- **Hardness 100%**

(8) **Zoom in the image to erase unwanted dark spots**

For PC User

- **Zoom Tool**
  - + Alt =

- **Hand Tool**
  - to drag the image

- Any Tools + Space Bar =
(9) The result after erasing all the dark spots and shadow

(10) File > Save as...

(1) Rename your file name under “File name”
(2) Select JPEG under “Format”

Click Save
How to Insert Line Drawing in Word

A workable format for presenting sign language drawings in print form is to use a table of three columns that measure 2 inches wide and 1 ½ inches high, with a second row immediately under that measures ¼ high. This second row is used for notation.

To create a table, first insert a table that is 3 columns and 2 rows, in a word document.

Select both the top row and make it exactly 1.5 inches high, do not change the bottom row.
Highlight the top row of the table and choose *AutoFit to Window*. This will keep the table cell the intended size, even when large images are inserted.

A table of two rows and three columns, used to display sign drawings.

<table>
<thead>
<tr>
<th>The basic sign drawing</th>
<th></th>
<th></th>
</tr>
</thead>
</table>
How to Add Arrows and Notations to Drawings in Word

Examples of Drawing on Figure Drawings Using Word Drawing Tools

To create arrows and movement indicators using Word's Drawing Tools:

**Basic Arrows**

1. Use the Drawing Toolbar to create an arrow.

   ![Drawing Toolbar](image)

   Select Arrows
   Select Weight of Line 1.5 to 2.5 points

**For Curved Lines and Arrows**

1. Select Curve Lines under the AutoShapes Menu.

   ![AutoShapes](image)

   Click at Multiple Points and Double click to finish
Sign Shapes CSH File for PhotoShop

Most of the line drawings used to depict signs are enhanced by the inclusion of motion and direction indication shapes and arrows. Generally there are approximately 25 “universal” shapes that are used to notate most sign languages.

In an effort to reduce the creation and reproduction of the basic shapes used to notate signs, a special CSH file was created by the project team that can be incorporated into PC and Mac versions of Photoshop CS.

The following narrative describes the installation of the CSH file into Photoshop and then describes how the shapes can be added to line drawings in PhotoShop.

A copy of the most current CSH file can be obtained by contacting the authors.

Installing CSH files

***Before opening Photoshop, COPY and PASTE the .csh file into:

My Computer > Local Disk > Program Files > Adobe > Adobe Photoshop > Presets > Custom Shapes

COPY and PASTE custom made Custom Shape file “.csh” example: “Sign_Shapes.csh”
(1) Open Photoshop

(2) Tool Bar > Custom Shape Tool

Click and hold down the menu
(3) click the small arrow next to **Shape** > click the small arrow > **Replace Shape**

Select “Sign_Shape” (the CSH file you have just COPIED and PASTED) > click **Load**
Using Custom Shape Tools

(1) Select "Custom Shape Tool" from Tool box
Make sure Foreground is Black

(2) Click the small arrow
Select options, depending on your preference ("Defined Proportions" recommended)
(3) - Open the Image you want to use ①
- Make a new layer ②
(if you don’t see a “Layers” palette on the screen, go Window > Layers)

(4) - Click the small arrow ①
- Select an arrows from the drop down menu ②
(5) Place the arrow you picked, Click and drag
(7) **Move, Scale, and Rotate**

**Edit > Free Transform**

or

$$\text{Ctrl} + \ T$$

You will see a box around the arrow

To **Move**

Click and hold the arrow, and drag to move

To **Scale** and **Rotate**

By placing your mouse on the edge of the box

appear for scale

appear for rotate

*** hit **Enter** to confirm
1) Open **Adobe Illustrator**

2) **File > New** > select **Letter size** > **OK**

3) Draw a **line** using **Pen Tool**

- Make sure Foreground is “None (/)”

- Change **Stroke Weight** depend on your image

**Window > Stroke**
4) Draw a triangle using Pen Tool

- Make sure Foreground is Black

To make Foreground Black, select the Foreground by clicking on the Foreground box, then get black from the Color Palette

Window > Color

- Start drawing a triangle
- Can move, scale, and rotate by selecting an object using selection tool

- Combining with a line to create an arrow

**Before you save the file, be sure that you have removed any extraneous object (lines, arrowheads, etc.) from the drawing.**
5) **File > Save as...**

Select **JPEG**

![Dialogue box for saving as JPEG](image)

Click **Save**

↓

You will see this dialogue box next

Set Image quality: **10, Maximum**

![JPEG Options dialogue box](image)

Set **Quality 10, Maximum**

Click **OK**
6) Open **Microsoft Word**

7) **Insert > Picture > From File**

   to get images

   ![Image with instructions](image1.png)

   ① Insert an image

   ② Insert an arrow

8) **View > Toolbars > Picture**  to open Picture tool box

   ![Image with toolbars](image2.png)
9) select “Arrow” by clicking on it

Go Picture toolbar box → pick “In Front of Text”

10) click the “Arrow” → hold down the mouse → drag to the place you want

11) click **Set Transparent Color** → click on background arrow to remove the background

Click on background to remove  
Removed the background